Fourtitude.com - 09G transmission valve body replaced...LOST REVERSE?!?!
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Fourtitude.com


    Results 1 to 4 of 4
    1. 09-07-2019 07:46 PM #1
      Hey all! So i have some mechanical know-how and today i pulled out my old valve body on my 2007 VW Jetta 2.5 with the stupid 09G transmission.

      I made sure to note which connections went where, installed the new one, plugged everything back in how it was when i took it out and when i put the pan on and refilled about 5 1/2 qt's and started going through gears.

      The trans will go into Reverse but it doesnt engage.

      Low fluid level? Could a pin not be connected? Other issue?

      I also noticed when i went to check the old VB there are bolts all over the VB and i want to say the one i installed didnt have them, would the bolts missing on the body itself make a difference?

      i know its inevitable that i drain the oil back out and take the pan off but before i get into that does anyone have any input? Someone get back to me on this please and thank you!\

    2. Remove Advertisements

      Advertisements
       

    3. Junior Member
      Join Date
      Aug 28th, 2016
      Location
      Chula Vista, CA
      Posts
      70
      Cars
      Previous: 1986 GTI, 1992 Corrado VR6 Current: 2010 Jetta 2.5, 2017 Golf R DSG
      09-08-2019 03:09 PM #2
      Did you fill transmission as per VW specifications?

      Sent from my SM-N960U using Tapatalk

    4. Junior Member
      Join Date
      Aug 28th, 2016
      Location
      Chula Vista, CA
      Posts
      70
      Cars
      Previous: 1986 GTI, 1992 Corrado VR6 Current: 2010 Jetta 2.5, 2017 Golf R DSG
      09-08-2019 03:14 PM #3
      https://www.blauparts.com/install_in...structions.pdf

      Sent from my SM-N960U using Tapatalk

    5. Remove Advertisements

      Advertisements
       

    6. 09-09-2019 04:04 PM #4
      Check the manual from page 144 and down.

      http://www.evosoft.dk/diagrams/09G.pdf

      Make sure you installed correctly the selector lever.
      DSG Freak - DSG Mecharonic is my name. Just ask and I will try to answer, IF I have time been there done that

      DSG Help Services - HERE

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •