Fourtitude.com - Quick easy 2.5l question
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Fourtitude.com


    Results 1 to 9 of 9
    1. 08-06-2019 04:51 PM #1
      Cannot find the answer to this simple question, I have a 2010 Jetta with the 2.5l obviously.

      Number #2 coolant sensor has failed, looking for a replacement, in my searches I cannot verify if it's the same sensor as #1.

      I usually order from Rockauto, when I look at their list it shows only 1 sensor, is this sensor used in both #1 & #2 positions?

      Thanks Vortex.

    2. Remove Advertisements

      Advertisements
       

    3. Member JaxPlanet's Avatar
      Join Date
      Sep 17th, 2018
      Posts
      153
      Cars
      2012 JSW 2.5
      08-09-2019 11:46 AM #2
      Quote Originally Posted by ArizonaGLIOwner View Post
      Cannot find the answer to this simple question, I have a 2010 Jetta with the 2.5l obviously.

      Number #2 coolant sensor has failed, looking for a replacement, in my searches I cannot verify if it's the same sensor as #1.

      I usually order from Rockauto, when I look at their list it shows only 1 sensor, is this sensor used in both #1 & #2 positions?

      Thanks Vortex.
      Look up the part number at parts.vw.com. If you still aren't sure, call any VW dealer's service center and ask them.

    4. Member
      Join Date
      Apr 17th, 2014
      Posts
      1,038
      Cars
      2011 Jetta SE
      08-22-2019 05:23 PM #3
      When I was replacing coolant sensor, I had searched the imaginary 2nd one for about half an hour but couldn't find anything other than the one connected to the block. I think we have only one sensor. It is grey btw. p/n 06A919501A.

    5. Remove Advertisements

      Advertisements
       

    6. 10-14-2019 01:47 AM #4
      bottom of the rad on drivers side, close to where the bottom hose connects to the rad. that's where the 2nd one SHOULD be, my car is a 07 Rabbit, so I could be wrong.

      I had an issue where the sensor was fine but the wire corroded and the computer didn't see it anymore... Fixed the wire and it's working again.


      The sensor in the thermostat housing on the block is the main one that sends to the cluster I think, that's the top side sensor.

      if I have this right, the computer takes a reading from both sensors and does quick math to determine if it needs to turn on the cooling fans.


      I could be wrong, but yeah, hope this helps you, it's been awhile since I had to fix this.
      Last edited by technix77; 10-14-2019 at 01:49 AM.

    7. Member
      Join Date
      Apr 17th, 2014
      Posts
      1,038
      Cars
      2011 Jetta SE
      10-14-2019 12:44 PM #5
      The one on the block is located at the driver's side coolant flange, close to the SAI sensor. I've checked around the rad but there is no sensor there. Not sure about the thermostat housing cause it is hidden under the air intake manifold and very dark there.
      2011 CBTA. The OEM catalog shows only one sensor. I'm almost sure the imaginary 2nd sensor is the same part number.

      This topic worth discussing btw. We still don't know how many CTS we have.
      Last edited by Ronny Bensys; 10-14-2019 at 12:52 PM.

    8. Junior Member
      Join Date
      Apr 14th, 2016
      Location
      SoFL
      Posts
      73
      12-05-2019 06:09 PM #6
      Pretty sure we have two temp sensors. One connected to the block and one on the bottom between the lower water hose and radiator. I replaced both sensors when I did my water pump few months ago. Car is a 2013 Jetta SE.

    9. Member
      Join Date
      Apr 17th, 2014
      Posts
      1,038
      Cars
      2011 Jetta SE
      12-06-2019 02:29 PM #7
      Quote Originally Posted by siryip View Post
      Pretty sure we have two temp sensors. One connected to the block and one on the bottom between the lower water hose and radiator. I replaced both sensors when I did my water pump few months ago. Car is a 2013 Jetta SE.
      Could you please post a photo of the 2nd one? Just curious about its location. I've searched few times in the engine bay.

    10. Junior Member
      Join Date
      Apr 14th, 2016
      Location
      SoFL
      Posts
      73
      12-06-2019 06:51 PM #8

    11. Member
      Join Date
      Apr 17th, 2014
      Posts
      1,038
      Cars
      2011 Jetta SE
      12-08-2019 06:53 AM #9
      Quote Originally Posted by siryip View Post
      Link is broken.

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •