Fourtitude.com - Oil Pressure Light - Help
Username or Email Address
Do you already have an account?
Forgot your password?
  • Log in or Sign up

    Fourtitude.com


    Results 1 to 10 of 10
    1. Member
      Join Date
      Jul 1st, 1999
      Posts
      12,101
      Blog Entries
      1
      09-02-2016 09:04 AM #1
      Long story short, I screwed up my oil change the day before yesterday and forgot to push the orange nipple (relief valve) back into the oil filter housing. Needless to say I had a oil leak from the bottom of the oil filter housing that was fairly significant. I fixed the problem, cleaned up my mess, but the annoying dinging/flashing of "OIL PRESSURE" is happening ONLY when I take a turn. If the car is traveling straight, no oil pressure warning

      Does anyone know how I go about fixing this issue? TIA.

      SOLVED: Added more oil to turn off "Oil Pressure" warning/indicator.
      Last edited by Xymox; 09-02-2016 at 03:42 PM.

    2. Remove Advertisements

      Advertisements
       

    3. 09-02-2016 10:17 AM #2
      Did you add more oil to compensate for the oil that leaked?


      Sent from my iPhone using Tapatalk

    4. Member
      Join Date
      Jul 1st, 1999
      Posts
      12,101
      Blog Entries
      1
      09-02-2016 10:19 AM #3
      Quote Originally Posted by clashofhope View Post
      Did you add more oil to compensate for the oil that leaked?

      I did not. But wouldn't this cause the car to throw the orange low oil light? I just checked the car and I found no oil on the dipstick, which leads me to wonder if the oil pump failed with this mishap.

    5. 09-02-2016 10:51 AM #4
      Sounds like you have less than 4 quarts of oil in your car. I would add more oil.


      Sent from my iPhone using Tapatalk

    6. Member
      Join Date
      Jul 1st, 1999
      Posts
      12,101
      Blog Entries
      1
      09-02-2016 11:00 AM #5
      Quote Originally Posted by clashofhope View Post
      Sounds like you have less than 4 quarts of oil in your car. I would add more oil.
      Yeah? But wouldn't I get the yellow "low oil" indicator? I know I had to lose a lot of oil.

      Appreciate your help, man. Your user name gives me hope.
      Last edited by Xymox; 09-02-2016 at 11:21 AM.

    7. 09-02-2016 11:46 AM #6
      The yellow light is a warning for when you get to around 4 quarts.

      No worries. Good luck with your car.


      Sent from my iPhone using Tapatalk

    8. Member
      Join Date
      Jul 1st, 1999
      Posts
      12,101
      Blog Entries
      1
      09-02-2016 11:48 AM #7
      Quote Originally Posted by clashofhope View Post
      The yellow light is a warning for when you get to around 4 quarts.
      I understand the yellow light/warning is for low oil and the red light/warning is for oil pressure. I'm just curious why I would only receive the red light/warning (oil pressure) and not the yellow light/warning if I'm too low on oil.

    9. 09-02-2016 11:53 AM #8
      I've had pretty much the same thing happen to me except it was because the person who changed my oil didn't screw my oil filter housing in all the way. It just kinda skipped the warning. I added oil, everything was fine.


      Sent from my iPhone using Tapatalk

    10. Member
      Join Date
      Jul 1st, 1999
      Posts
      12,101
      Blog Entries
      1
      09-02-2016 11:56 AM #9
      Quote Originally Posted by clashofhope View Post
      I've had pretty much the same thing happen to me except it was because the person who changed my oil didn't screw my oil filter housing in all the way. It just kinda skipped the warning. I added oil, everything was fine.
      I'll hit Walmart after work and grab another 5 quarts. I lost a slew of oil from the bottom of the oil filter housing--so much it completely coated the underside of my car from front to very back.

      Thanks again.

    11. Member
      Join Date
      Jul 1st, 1999
      Posts
      12,101
      Blog Entries
      1
      09-02-2016 03:39 PM #10
      Quote Originally Posted by clashofhope View Post
      I've had pretty much the same thing happen to me except it was because the person who changed my oil didn't screw my oil filter housing in all the way. It just kinda skipped the warning. I added oil, everything was fine.


      Sent from my iPhone using Tapatalk
      Well, you were right, my friend. I grabbed a 5qt. jug of oil and had to dump nearly 4qts. It's now regiatering on the dipstick and after test driving for 6 or so miles on twisty back roads the "Oil Pressure" light is off. Thank you. And silly Audi didn't bother to have a dual warning system so you'd know the oil was low as well as a oil pressure problem. Anyways, thanks for the help.

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •